加入收藏 | 设为首页 | 会员中心 | 我要投稿 | 在线留言 | RSS
成网科技业务包括域名空间企业网站制作
 
国际域名com/net/org仅售80元/年
1G独立空间(PHP+MYSQL)仅售600元/年
您当前的位置:首页 > 操作系统 > RedHat/Centos

在CentOS中制作BGP路由器的教程

时间:2015-08-29 12:11:43  来源:开源中文社区  作者:佚名  点击:

Quagga是一个开源路由软件套件。在这个教程中,我将会重点讲讲如何把一个Linux系统变成一个BGP路由器,还是使用Quagga,演示如何建立BGP与其它BGP路由器对等。Gy5成网科技_开平网站建设_开平网站制作_开平企业网站_开平网页设计_江门网站建设

在我们进入细节之前,一些BGP的背景知识还是必要的。边界网关协议(即BGP)是互联网的域间路由协议的实际标准。在BGP术语中,全球互联网是由成千上万相关联的自治系统(AS)组成,其中每一个AS代表每一个特定运营商提供的一个网络管理域(据说,美国前总统乔治.布什都有自己的 AS 编号)。Gy5成网科技_开平网站建设_开平网站制作_开平企业网站_开平网页设计_江门网站建设
为了使其网络在全球范围内路由可达,每一个AS需要知道如何在英特网中到达其它的AS。这时候就需要BGP出来扮演这个角色了。BGP是一个AS去与相邻的AS交换路由信息的语言。这些路由信息通常被称为BGP线路或者BGP前缀。包括AS号(ASN;全球唯一号码)以及相关的IP地址块。一旦所有的BGP线路被当地的BGP路由表学习和记录,每一个AS将会知道如何到达互联网的任何公网IP。Gy5成网科技_开平网站建设_开平网站制作_开平企业网站_开平网页设计_江门网站建设

在不同域(AS)之间路由的能力是BGP被称为外部网关协议(EGP)或者域间协议的主要原因。就如一些路由协议,例如OSPF、IS-IS、RIP和EIGRP都是内部网关协议(IGPs)或者域内路由协议,用于处理一个域内的路由.Gy5成网科技_开平网站建设_开平网站制作_开平企业网站_开平网页设计_江门网站建设
测试方案Gy5成网科技_开平网站建设_开平网站制作_开平企业网站_开平网页设计_江门网站建设

在这个教程中,让我们来使用以下拓扑。Gy5成网科技_开平网站建设_开平网站制作_开平企业网站_开平网页设计_江门网站建设
201577152001767.jpg (640×194)Gy5成网科技_开平网站建设_开平网站制作_开平企业网站_开平网页设计_江门网站建设

我们假设运营商A想要建立一个BGP来与运营商B对等交换路由。它们的AS号和IP地址空间的细节如下所示:Gy5成网科技_开平网站建设_开平网站制作_开平企业网站_开平网页设计_江门网站建设

    运营商 A: ASN (100), IP地址空间 (100.100.0.0/22), 分配给BGP路由器eth1网卡的IP地址(100.100.1.1)Gy5成网科技_开平网站建设_开平网站制作_开平企业网站_开平网页设计_江门网站建设

    运营商 B: ASN (200), IP地址空间 (200.200.0.0/22), 分配给BGP路由器eth1网卡的IP地址(200.200.1.1)Gy5成网科技_开平网站建设_开平网站制作_开平企业网站_开平网页设计_江门网站建设

路由器A和路由器B使用100.100.0.0/30子网来连接到对方。从理论上来说,任何子网从运营商那里都是可达的、可互连的。在真实场景中,建议使用掩码为30位的公网IP地址空间来实现运营商A和运营商B之间的连通。Gy5成网科技_开平网站建设_开平网站制作_开平企业网站_开平网页设计_江门网站建设
在 CentOS中安装QuaggaGy5成网科技_开平网站建设_开平网站制作_开平企业网站_开平网页设计_江门网站建设

如果Quagga还没安装好,我们可以使用yum来安装Quagga。Gy5成网科技_开平网站建设_开平网站制作_开平企业网站_开平网页设计_江门网站建设

   
复制代码代码如下:# yum install quaggaGy5成网科技_开平网站建设_开平网站制作_开平企业网站_开平网页设计_江门网站建设

如果你正在使用的是CentOS7系统,你需要应用一下策略来设置SELinux。否则,SElinux将会阻止Zebra守护进程写入它的配置目录。如果你正在使用的是CentOS6,你可以跳过这一步。Gy5成网科技_开平网站建设_开平网站制作_开平企业网站_开平网页设计_江门网站建设

   
复制代码代码如下:# setsebool -P zebra_write_config 1Gy5成网科技_开平网站建设_开平网站制作_开平企业网站_开平网页设计_江门网站建设

Quagga软件套件包含几个守护进程,这些进程可以协同工作。关于BGP路由,我们将把重点放在建立以下2个守护进程。Gy5成网科技_开平网站建设_开平网站制作_开平企业网站_开平网页设计_江门网站建设

    Zebra:一个核心守护进程用于内核接口和静态路由.Gy5成网科技_开平网站建设_开平网站制作_开平企业网站_开平网页设计_江门网站建设
    BGPd:一个BGP守护进程.Gy5成网科技_开平网站建设_开平网站制作_开平企业网站_开平网页设计_江门网站建设

配置日志记录Gy5成网科技_开平网站建设_开平网站制作_开平企业网站_开平网页设计_江门网站建设

在Quagga被安装后,下一步就是配置Zebra来管理BGP路由器的网络接口。我们通过创建一个Zebra配置文件和启用日志记录来开始第一步。Gy5成网科技_开平网站建设_开平网站制作_开平企业网站_开平网页设计_江门网站建设

   
复制代码代码如下: # cp /usr/share/doc/quagga-XXXXX/zebra.conf.sample /etc/quagga/zebra.conf Gy5成网科技_开平网站建设_开平网站制作_开平企业网站_开平网页设计_江门网站建设

在CentOS6系统中:Gy5成网科技_开平网站建设_开平网站制作_开平企业网站_开平网页设计_江门网站建设

  
复制代码代码如下: # service zebra startGy5成网科技_开平网站建设_开平网站制作_开平企业网站_开平网页设计_江门网站建设
# chkconfig zebra onGy5成网科技_开平网站建设_开平网站制作_开平企业网站_开平网页设计_江门网站建设

在CentOS7系统中:Gy5成网科技_开平网站建设_开平网站制作_开平企业网站_开平网页设计_江门网站建设

   
复制代码代码如下:# systemctl start zebraGy5成网科技_开平网站建设_开平网站制作_开平企业网站_开平网页设计_江门网站建设
# systemctl enable zebra Gy5成网科技_开平网站建设_开平网站制作_开平企业网站_开平网页设计_江门网站建设

Quagga提供了一个叫做vtysh特有的命令行工具,你可以输入与路由器厂商(例如Cisco和Juniper)兼容和支持的命令。我们将使用vtysh shell来配置BGP路由在教程的其余部分。Gy5成网科技_开平网站建设_开平网站制作_开平企业网站_开平网页设计_江门网站建设

启动vtysh shell 命令,输入:Gy5成网科技_开平网站建设_开平网站制作_开平企业网站_开平网页设计_江门网站建设

   
复制代码代码如下: # vtyshGy5成网科技_开平网站建设_开平网站制作_开平企业网站_开平网页设计_江门网站建设

提示将被改成该主机名,这表明你是在vtysh shell中。Gy5成网科技_开平网站建设_开平网站制作_开平企业网站_开平网页设计_江门网站建设

   
复制代码代码如下: Router-A#Gy5成网科技_开平网站建设_开平网站制作_开平企业网站_开平网页设计_江门网站建设

现在我们将使用以下命令来为Zebra配置日志文件:Gy5成网科技_开平网站建设_开平网站制作_开平企业网站_开平网页设计_江门网站建设

   
复制代码代码如下:Router-A# configure terminalGy5成网科技_开平网站建设_开平网站制作_开平企业网站_开平网页设计_江门网站建设
Router-A(config)# log file /var/log/quagga/quagga.logGy5成网科技_开平网站建设_开平网站制作_开平企业网站_开平网页设计_江门网站建设
Router-A(config)# exitGy5成网科技_开平网站建设_开平网站制作_开平企业网站_开平网页设计_江门网站建设

永久保存Zebra配置:Gy5成网科技_开平网站建设_开平网站制作_开平企业网站_开平网页设计_江门网站建设

   
复制代码代码如下: Router-A# writeGy5成网科技_开平网站建设_开平网站制作_开平企业网站_开平网页设计_江门网站建设

在路由器B操作同样的步骤。Gy5成网科技_开平网站建设_开平网站制作_开平企业网站_开平网页设计_江门网站建设
配置对等的IP地址Gy5成网科技_开平网站建设_开平网站制作_开平企业网站_开平网页设计_江门网站建设

下一步,我们将在可用的接口上配置对等的IP地址。Gy5成网科技_开平网站建设_开平网站制作_开平企业网站_开平网页设计_江门网站建设

   
复制代码代码如下:Router-A# show interface #显示接口信息</p><p> Interface eth0 is up, line protocol detection is disabledGy5成网科技_开平网站建设_开平网站制作_开平企业网站_开平网页设计_江门网站建设
. . . . .Gy5成网科技_开平网站建设_开平网站制作_开平企业网站_开平网页设计_江门网站建设
Interface eth1 is up, line protocol detection is disabledGy5成网科技_开平网站建设_开平网站制作_开平企业网站_开平网页设计_江门网站建设
. . . . .Gy5成网科技_开平网站建设_开平网站制作_开平企业网站_开平网页设计_江门网站建设

配置eth0接口的参数:Gy5成网科技_开平网站建设_开平网站制作_开平企业网站_开平网页设计_江门网站建设

   
复制代码代码如下:site-A-RTR# configure terminalGy5成网科技_开平网站建设_开平网站制作_开平企业网站_开平网页设计_江门网站建设
site-A-RTR(config)# interface eth0Gy5成网科技_开平网站建设_开平网站制作_开平企业网站_开平网页设计_江门网站建设
site-A-RTR(config-if)# ip address 100.100.0.1/30Gy5成网科技_开平网站建设_开平网站制作_开平企业网站_开平网页设计_江门网站建设
site-A-RTR(config-if)# description "to Router-B"Gy5成网科技_开平网站建设_开平网站制作_开平企业网站_开平网页设计_江门网站建设
site-A-RTR(config-if)# no shutdownGy5成网科技_开平网站建设_开平网站制作_开平企业网站_开平网页设计_江门网站建设
site-A-RTR(config-if)# exitGy5成网科技_开平网站建设_开平网站制作_开平企业网站_开平网页设计_江门网站建设

继续配置eth1接口的参数:Gy5成网科技_开平网站建设_开平网站制作_开平企业网站_开平网页设计_江门网站建设

   
复制代码代码如下: site-A-RTR(config)# interface eth1Gy5成网科技_开平网站建设_开平网站制作_开平企业网站_开平网页设计_江门网站建设
site-A-RTR(config-if)# ip address 100.100.1.1/24Gy5成网科技_开平网站建设_开平网站制作_开平企业网站_开平网页设计_江门网站建设
site-A-RTR(config-if)# description "test ip from provider A network"Gy5成网科技_开平网站建设_开平网站制作_开平企业网站_开平网页设计_江门网站建设
site-A-RTR(config-if)# no shutdownGy5成网科技_开平网站建设_开平网站制作_开平企业网站_开平网页设计_江门网站建设
site-A-RTR(config-if)# exitGy5成网科技_开平网站建设_开平网站制作_开平企业网站_开平网页设计_江门网站建设

现在确认配置:Gy5成网科技_开平网站建设_开平网站制作_开平企业网站_开平网页设计_江门网站建设

   
复制代码代码如下:Router-A# show interface </p><p> Interface eth0 is up, line protocol detection is disabledGy5成网科技_开平网站建设_开平网站制作_开平企业网站_开平网页设计_江门网站建设
Description: "to Router-B"Gy5成网科技_开平网站建设_开平网站制作_开平企业网站_开平网页设计_江门网站建设
inet 100.100.0.1/30 broadcast 100.100.0.3Gy5成网科技_开平网站建设_开平网站制作_开平企业网站_开平网页设计_江门网站建设
Interface eth1 is up, line protocol detection is disabledGy5成网科技_开平网站建设_开平网站制作_开平企业网站_开平网页设计_江门网站建设
Description: "test ip from provider A network"Gy5成网科技_开平网站建设_开平网站制作_开平企业网站_开平网页设计_江门网站建设
inet 100.100.1.1/24 broadcast 100.100.1.255</p><p> Router-A# show interface description #显示接口描述</p><p> Interface Status Protocol DescriptionGy5成网科技_开平网站建设_开平网站制作_开平企业网站_开平网页设计_江门网站建设
eth0 up unknown "to Router-B"Gy5成网科技_开平网站建设_开平网站制作_开平企业网站_开平网页设计_江门网站建设
eth1 up unknown "test ip from provider A network"Gy5成网科技_开平网站建设_开平网站制作_开平企业网站_开平网页设计_江门网站建设

如果一切看起来正常,别忘记保存配置。Gy5成网科技_开平网站建设_开平网站制作_开平企业网站_开平网页设计_江门网站建设

   
复制代码代码如下:Router-A# writeGy5成网科技_开平网站建设_开平网站制作_开平企业网站_开平网页设计_江门网站建设

同样地,在路由器B重复一次配置。Gy5成网科技_开平网站建设_开平网站制作_开平企业网站_开平网页设计_江门网站建设

在我们继续下一步之前,确认下彼此的IP是可以ping通的。Gy5成网科技_开平网站建设_开平网站制作_开平企业网站_开平网页设计_江门网站建设

   
复制代码代码如下:Router-A# ping 100.100.0.2 </p><p> PING 100.100.0.2 (100.100.0.2) 56(84) bytes of data.Gy5成网科技_开平网站建设_开平网站制作_开平企业网站_开平网页设计_江门网站建设
64 bytes from 100.100.0.2: icmp_seq=1 ttl=64 time=0.616 msGy5成网科技_开平网站建设_开平网站制作_开平企业网站_开平网页设计_江门网站建设

下一步,我们将继续配置BGP对等和前缀设置。Gy5成网科技_开平网站建设_开平网站制作_开平企业网站_开平网页设计_江门网站建设
配置BGP对等Gy5成网科技_开平网站建设_开平网站制作_开平企业网站_开平网页设计_江门网站建设

Quagga守护进程负责BGP的服务叫bgpd。首先我们来准备它的配置文件。Gy5成网科技_开平网站建设_开平网站制作_开平企业网站_开平网页设计_江门网站建设

   
复制代码代码如下:# cp /usr/share/doc/quagga-XXXXXXX/bgpd.conf.sample /etc/quagga/bgpd.conf Gy5成网科技_开平网站建设_开平网站制作_开平企业网站_开平网页设计_江门网站建设

在CentOS6系统中:Gy5成网科技_开平网站建设_开平网站制作_开平企业网站_开平网页设计_江门网站建设

   
复制代码代码如下: # service bgpd startGy5成网科技_开平网站建设_开平网站制作_开平企业网站_开平网页设计_江门网站建设
# chkconfig bgpd onGy5成网科技_开平网站建设_开平网站制作_开平企业网站_开平网页设计_江门网站建设

在CentOS7中:Gy5成网科技_开平网站建设_开平网站制作_开平企业网站_开平网页设计_江门网站建设

   
复制代码代码如下: # systemctl start bgpdGy5成网科技_开平网站建设_开平网站制作_开平企业网站_开平网页设计_江门网站建设
# systemctl enable bgpdGy5成网科技_开平网站建设_开平网站制作_开平企业网站_开平网页设计_江门网站建设

现在,让我们来进入Quagga 的shell。Gy5成网科技_开平网站建设_开平网站制作_开平企业网站_开平网页设计_江门网站建设

   
复制代码代码如下:# vtyshGy5成网科技_开平网站建设_开平网站制作_开平企业网站_开平网页设计_江门网站建设

第一步,我们要确认当前没有已经配置的BGP会话。在一些版本,我们可能会发现一个AS号为7675的BGP会话。由于我们不需要这个会话,所以把它移除。Gy5成网科技_开平网站建设_开平网站制作_开平企业网站_开平网页设计_江门网站建设

   
复制代码代码如下:Router-A# show running-config </p><p> ... ... ...Gy5成网科技_开平网站建设_开平网站制作_开平企业网站_开平网页设计_江门网站建设
router bgp 7675Gy5成网科技_开平网站建设_开平网站制作_开平企业网站_开平网页设计_江门网站建设
bgp router-id 200.200.1.1Gy5成网科技_开平网站建设_开平网站制作_开平企业网站_开平网页设计_江门网站建设
... ... ... Gy5成网科技_开平网站建设_开平网站制作_开平企业网站_开平网页设计_江门网站建设

我们将移除一些预先配置好的BGP会话,并建立我们所需的会话取而代之。Gy5成网科技_开平网站建设_开平网站制作_开平企业网站_开平网页设计_江门网站建设

   
复制代码代码如下:Router-A# configure terminalGy5成网科技_开平网站建设_开平网站制作_开平企业网站_开平网页设计_江门网站建设
Router-A(config)# no router bgp 7675Gy5成网科技_开平网站建设_开平网站制作_开平企业网站_开平网页设计_江门网站建设
Router-A(config)# router bgp 100Gy5成网科技_开平网站建设_开平网站制作_开平企业网站_开平网页设计_江门网站建设
Router-A(config)# no auto-summaryGy5成网科技_开平网站建设_开平网站制作_开平企业网站_开平网页设计_江门网站建设
Router-A(config)# no synchronizaitonGy5成网科技_开平网站建设_开平网站制作_开平企业网站_开平网页设计_江门网站建设
Router-A(config-router)# neighbor 100.100.0.2 remote-as 200Gy5成网科技_开平网站建设_开平网站制作_开平企业网站_开平网页设计_江门网站建设
Router-A(config-router)# neighbor 100.100.0.2 description "provider B"Gy5成网科技_开平网站建设_开平网站制作_开平企业网站_开平网页设计_江门网站建设
Router-A(config-router)# exitGy5成网科技_开平网站建设_开平网站制作_开平企业网站_开平网页设计_江门网站建设
Router-A(config)# exitGy5成网科技_开平网站建设_开平网站制作_开平企业网站_开平网页设计_江门网站建设
Router-A# write Gy5成网科技_开平网站建设_开平网站制作_开平企业网站_开平网页设计_江门网站建设

路由器B将用同样的方式来进行配置,以下配置提供作为参考。Gy5成网科技_开平网站建设_开平网站制作_开平企业网站_开平网页设计_江门网站建设

   
复制代码代码如下:Router-B# configure terminalGy5成网科技_开平网站建设_开平网站制作_开平企业网站_开平网页设计_江门网站建设
Router-B(config)# no router bgp 7675Gy5成网科技_开平网站建设_开平网站制作_开平企业网站_开平网页设计_江门网站建设
Router-B(config)# router bgp 200Gy5成网科技_开平网站建设_开平网站制作_开平企业网站_开平网页设计_江门网站建设
Router-B(config)# no auto-summaryGy5成网科技_开平网站建设_开平网站制作_开平企业网站_开平网页设计_江门网站建设
Router-B(config)# no synchronizaitonGy5成网科技_开平网站建设_开平网站制作_开平企业网站_开平网页设计_江门网站建设
Router-B(config-router)# neighbor 100.100.0.1 remote-as 100Gy5成网科技_开平网站建设_开平网站制作_开平企业网站_开平网页设计_江门网站建设
Router-B(config-router)# neighbor 100.100.0.1 description "provider A"Gy5成网科技_开平网站建设_开平网站制作_开平企业网站_开平网页设计_江门网站建设
Router-B(config-router)# exitGy5成网科技_开平网站建设_开平网站制作_开平企业网站_开平网页设计_江门网站建设
Router-B(config)# exitGy5成网科技_开平网站建设_开平网站制作_开平企业网站_开平网页设计_江门网站建设
Router-B# writeGy5成网科技_开平网站建设_开平网站制作_开平企业网站_开平网页设计_江门网站建设

当相关的路由器都被配置好,两台路由器之间的对等将被建立。现在让我们通过运行下面的命令来确认:Gy5成网科技_开平网站建设_开平网站制作_开平企业网站_开平网页设计_江门网站建设

   
复制代码代码如下:Router-A# show ip bgp summary Gy5成网科技_开平网站建设_开平网站制作_开平企业网站_开平网页设计_江门网站建设
201577152045418.jpg (640×143)Gy5成网科技_开平网站建设_开平网站制作_开平企业网站_开平网页设计_江门网站建设

    从输出中,我们可以看到"State/PfxRcd"部分。如果对等关闭,输出将会显示"Idle"或者"Active'。请记住,单词'Active'这个词在路由器中总是不好的意思。它意味着路由器正在积极地寻找邻居、前缀或者路由。当对等是up状态,"State/PfxRcd"下的输出状态将会从特殊邻居接收到前缀号。Gy5成网科技_开平网站建设_开平网站制作_开平企业网站_开平网页设计_江门网站建设

在这个例子的输出中,BGP对等只是在AS100和AS200之间呈up状态。因此没有前缀被更改,所以最右边列的数值是0。Gy5成网科技_开平网站建设_开平网站制作_开平企业网站_开平网页设计_江门网站建设
配置前缀通告Gy5成网科技_开平网站建设_开平网站制作_开平企业网站_开平网页设计_江门网站建设

正如一开始提到,AS 100将以100.100.0.0/22作为通告,在我们的例子中AS 200将同样以200.200.0.0/22作为通告。这些前缀需要被添加到BGP配置如下。Gy5成网科技_开平网站建设_开平网站制作_开平企业网站_开平网页设计_江门网站建设

在路由器-A中:Gy5成网科技_开平网站建设_开平网站制作_开平企业网站_开平网页设计_江门网站建设

   
复制代码代码如下:Router-A# configure terminalGy5成网科技_开平网站建设_开平网站制作_开平企业网站_开平网页设计_江门网站建设
Router-A(config)# router bgp 100Gy5成网科技_开平网站建设_开平网站制作_开平企业网站_开平网页设计_江门网站建设
Router-A(config)# network 100.100.0.0/22Gy5成网科技_开平网站建设_开平网站制作_开平企业网站_开平网页设计_江门网站建设
Router-A(config)# exitGy5成网科技_开平网站建设_开平网站制作_开平企业网站_开平网页设计_江门网站建设
Router-A# writeGy5成网科技_开平网站建设_开平网站制作_开平企业网站_开平网页设计_江门网站建设

在路由器-B中:Gy5成网科技_开平网站建设_开平网站制作_开平企业网站_开平网页设计_江门网站建设

   
复制代码代码如下:Router-B# configure terminalGy5成网科技_开平网站建设_开平网站制作_开平企业网站_开平网页设计_江门网站建设
Router-B(config)# router bgp 200Gy5成网科技_开平网站建设_开平网站制作_开平企业网站_开平网页设计_江门网站建设
Router-B(config)# network 200.200.0.0/22Gy5成网科技_开平网站建设_开平网站制作_开平企业网站_开平网页设计_江门网站建设
Router-B(config)# exitGy5成网科技_开平网站建设_开平网站制作_开平企业网站_开平网页设计_江门网站建设
Router-B# writeGy5成网科技_开平网站建设_开平网站制作_开平企业网站_开平网页设计_江门网站建设

在这一点上,两个路由器会根据需要开始通告前缀。Gy5成网科技_开平网站建设_开平网站制作_开平企业网站_开平网页设计_江门网站建设
测试前缀通告Gy5成网科技_开平网站建设_开平网站制作_开平企业网站_开平网页设计_江门网站建设

首先,让我们来确认前缀的数量是否被改变了。Gy5成网科技_开平网站建设_开平网站制作_开平企业网站_开平网页设计_江门网站建设

   
复制代码代码如下: Router-A# show ip bgp summary Gy5成网科技_开平网站建设_开平网站制作_开平企业网站_开平网页设计_江门网站建设
201577152102079.jpg (640×146)Gy5成网科技_开平网站建设_开平网站制作_开平企业网站_开平网页设计_江门网站建设

    为了查看所接收的更多前缀细节,我们可以使用以下命令,这个命令用于显示邻居100.100.0.2所接收到的前缀总数。Gy5成网科技_开平网站建设_开平网站制作_开平企业网站_开平网页设计_江门网站建设

    
复制代码代码如下: Router-A# show ip bgp neighbors 100.100.0.2 advertised-routes Gy5成网科技_开平网站建设_开平网站制作_开平企业网站_开平网页设计_江门网站建设
201577152127435.jpg (640×165)Gy5成网科技_开平网站建设_开平网站制作_开平企业网站_开平网页设计_江门网站建设

     查看哪一个前缀是我们从邻居接收到的:Gy5成网科技_开平网站建设_开平网站制作_开平企业网站_开平网页设计_江门网站建设

   
复制代码代码如下:Router-A# show ip bgp neighbors 100.100.0.2 routes Gy5成网科技_开平网站建设_开平网站制作_开平企业网站_开平网页设计_江门网站建设
201577152143916.jpg (640×164)Gy5成网科技_开平网站建设_开平网站制作_开平企业网站_开平网页设计_江门网站建设

    我们也可以查看所有的BGP路由器:Gy5成网科技_开平网站建设_开平网站制作_开平企业网站_开平网页设计_江门网站建设

   
复制代码代码如下: Router-A# show ip bgp Gy5成网科技_开平网站建设_开平网站制作_开平企业网站_开平网页设计_江门网站建设
201577152200977.jpg (640×174)Gy5成网科技_开平网站建设_开平网站制作_开平企业网站_开平网页设计_江门网站建设

    以上的命令都可以被用于检查哪个路由器通过BGP在路由器表中被学习到。Gy5成网科技_开平网站建设_开平网站制作_开平企业网站_开平网页设计_江门网站建设

   
复制代码代码如下: Router-A# show ip route Gy5成网科技_开平网站建设_开平网站制作_开平企业网站_开平网页设计_江门网站建设

    代码: K - 内核路由, C - 已链接 , S - 静态 , R - 路由信息协议 , O - 开放式最短路径优先协议,Gy5成网科技_开平网站建设_开平网站制作_开平企业网站_开平网页设计_江门网站建设
     Gy5成网科技_开平网站建设_开平网站制作_开平企业网站_开平网页设计_江门网站建设
           I - 中间系统到中间系统的路由选择协议, B - 边界网关协议, > - 选择路由, * - FIB 路由Gy5成网科技_开平网站建设_开平网站制作_开平企业网站_开平网页设计_江门网站建设
     Gy5成网科技_开平网站建设_开平网站制作_开平企业网站_开平网页设计_江门网站建设
   
复制代码代码如下: C>* 100.100.0.0/30 is directly connected, eth0Gy5成网科技_开平网站建设_开平网站制作_开平企业网站_开平网页设计_江门网站建设
C>* 100.100.1.0/24 is directly connected, eth1Gy5成网科技_开平网站建设_开平网站制作_开平企业网站_开平网页设计_江门网站建设
B>* 200.200.0.0/22 [20/0] via 100.100.0.2, eth0, 00:06:45</p><p> Router-A# show ip route bgp </p><p> B>* 200.200.0.0/22 [20/0] via 100.100.0.2, eth0, 00:08:13Gy5成网科技_开平网站建设_开平网站制作_开平企业网站_开平网页设计_江门网站建设

BGP学习到的路由也将会在Linux路由表中出现。Gy5成网科技_开平网站建设_开平网站制作_开平企业网站_开平网页设计_江门网站建设

  
复制代码代码如下: [root@Router-A~]# ip route </p><p> 100.100.0.0/30 dev eth0 proto kernel scope link src 100.100.0.1Gy5成网科技_开平网站建设_开平网站制作_开平企业网站_开平网页设计_江门网站建设
100.100.1.0/24 dev eth1 proto kernel scope link src 100.100.1.1Gy5成网科技_开平网站建设_开平网站制作_开平企业网站_开平网页设计_江门网站建设
200.200.0.0/22 via 100.100.0.2 dev eth0 proto zebraGy5成网科技_开平网站建设_开平网站制作_开平企业网站_开平网页设计_江门网站建设

最后,我们将使用ping命令来测试连通。结果将成功ping通。Gy5成网科技_开平网站建设_开平网站制作_开平企业网站_开平网页设计_江门网站建设

   
复制代码代码如下: [root@Router-A~]# ping 200.200.1.1 -c 2Gy5成网科技_开平网站建设_开平网站制作_开平企业网站_开平网页设计_江门网站建设

总而言之,本教程将重点放在如何在CentOS系统中运行一个基本的BGP路由器。这个教程让你开始学习BGP的配置,一些更高级的设置例如设置过滤器、BGP属性调整、本地优先级和预先路径准备等,我将会在后续的教程中覆盖这些主题。Gy5成网科技_开平网站建设_开平网站制作_开平企业网站_开平网页设计_江门网站建设

希望这篇教程能给大家一些帮助。Gy5成网科技_开平网站建设_开平网站制作_开平企业网站_开平网页设计_江门网站建设
Gy5成网科技_开平网站建设_开平网站制作_开平企业网站_开平网页设计_江门网站建设

成网科技 www.it28.com竭诚为您服务!
开平网站建设_开平网站制作_开平企业网站_开平网页设计_江门网站建设_成网科技

更多
 


来顶一下
返回首页
返回首页
发表评论 共有条评论
用户名: 密码:
验证码: 匿名发表
推荐资讯
相关文章
栏目更新
栏目热门